Billing provider transaction issue - TravelBuy

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 16:42 IDT

Monitoring

We are in touch with TravelBuy about a service outage with its billing gateway, which appears to be affecting all transactions. They are working on a resolution, and we will update you with further information as it becomes available.
Posted Jul 17, 2025 - 15:21 IDT