The billing provider, ExrerpEXPPDK, is currently experiencing an outage.

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 09:31 IDT

Investigating

We are currently investigating this issue.
Posted Jul 18, 2025 - 08:16 IDT