Billing provider transaction issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Mar 08, 2026 - 11:54 IST

Investigating

We are currently engaged with one of our billing providers regarding a partial service outage impacting its billing gateway and affecting some transactions. We are in contact with the billing provider and will provide an update as soon as more information becomes available.
Posted Mar 08, 2026 - 11:16 IST
This incident affected: Latin America (Transactions), Rest of Europe (Transactions), and North America (Transactions).