Silent Machines in US

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 18:14 IDT

Investigating

We are currently investigating this issue.
Posted Jun 15, 2025 - 13:11 IDT
This incident affected: North America (Cellular Communication).