Billing provider transaction issue - Heimir

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Apr 07, 2025 - 14:52 IDT

Investigating

We are in touch with Heimir about a service outage with its billing gateway, which appears to be affecting transactions. They are working on a resolution, and we will update you with further information as it becomes available.
Posted Apr 07, 2025 - 13:36 IDT
This incident affected: Germany (Transactions).