Connectivity issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 13:26 IDT

Investigating

We are facing some intermittent connectivity issues affecting our customers in Poland region. We have reached out to our sim provider to confirm the issue
Posted Jun 25, 2025 - 13:04 IDT
This incident affected: Rest of Europe (Cellular Communication).