Roseman + Retail silent machines

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Jul 13, 2025 - 17:32 IDT

Investigating

We are currently investigating this issue.
Posted Jul 13, 2025 - 14:13 IDT
This incident affected: ישראל (Transactions).