Website Timeouts

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 18:29 IST

Investigating

We are currently experiencing timeout issues with the following sites: nayax.com, monyx.com, tigapo.nayax.com, evmeter.com. We are investigating and will provide updates as soon as possible.
Posted Mar 19, 2026 - 18:12 IST