Device connectivity issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Aug 31, 2025 - 18:03 IDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 31, 2025 - 17:44 IDT

Investigating

We are currently experiencing a device connectivity issue affecting all Nayax regions. Some devices are unable to complete the power-up cycle as expected and remain stuck on the “TCPIP OK” screen for an extended period.
Our Development team is actively investigating the root cause and working to resolve the issue with the highest priority.
We will continue to provide updates as more information becomes available.
Thank you for your patience and understanding.
Posted Aug 31, 2025 - 17:16 IDT
This incident affected: Nayax Global Solution (CORE, Telemetry).