Billing provider transaction issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted May 12, 2026 - 10:20 IDT

Identified

Our partner Nuvei has advised of a service outage with its billing gateway, which appears to be affecting some transactions. They are working on a resolution and we will update you with further information as it becomes available.
Posted May 12, 2026 - 09:48 IDT
This incident affected: Rest of Europe (Transactions) and North America (Transactions).