Services degraded performance

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted May 19, 2025 - 12:25 IDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 19, 2025 - 11:29 IDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 19, 2025 - 11:19 IDT

Investigating

We are working to resolve an issue of degraded performance.
Posted May 19, 2025 - 11:02 IDT
This incident affected: Nayax Global Solution (Monyx).