Website connectivity issues

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted May 11, 2026 - 17:41 IDT

Investigating

We are facing some intermittent website connectivity issues. Our R&D team is investigating this on priority, and we will keep you posted on the progress.
Posted May 11, 2026 - 17:14 IDT