Billing provider transaction issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 23:10 IDT

Update

We are continuing to investigate this issue.
Posted Aug 27, 2026 - 13:39 IDT

Investigating

We are aware of an increase in declined card transactions affecting the TravelBuy billing provider. Our NOC team is engaged with the provider and is actively monitoring the situation. We will share further information as soon as we have an update.
Posted Aug 27, 2026 - 10:29 IDT
This incident affected: Africa & Middle East (Transactions).