Website connection issues

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted May 27, 2026 - 21:34 IDT

Investigating

We have identified intermittent connection issues with Nayax.com. Our teams are working to resolve this issue as soon as possible, we will continue to provide updates as they become available.
Posted May 27, 2026 - 18:00 IDT