Billing provider transaction issue

Incident Report for Nayax

Resolved

Our R&D team has resolved the issue and is now working on all regions.
Posted Aug 08, 2025 - 16:09 IDT

Investigating

We are in touch with Travelbuy about a service outage with its billing gateway, which appears to be affecting all transactions. They are working on a resolution, and we will update you with further information as it becomes available.
Posted Aug 08, 2025 - 15:55 IDT
This incident affected: Africa & Middle East (Transactions).