Replication issues and server latency

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 17:06 IST

Update

We are continuing to investigate this issue.
Posted Dec 03, 2025 - 14:30 IST

Investigating

Our engineers are currently handling a latency issue on Nayax Core (DCS), which has been causing a 30-minute gap between our servers. You may be experiencing a delay in the display of transactional data in reports, in the creation of new machines or entities, and with the display of prepaid card transactions and credit card revalue actions. Please be assured that there is no impact on transactions in the field and the issues are visual only. We apologize for the inconvenience caused and will provide more information as it becomes available.
Posted Dec 03, 2025 - 10:59 IST
This incident affected: Nayax Global Solution (CORE).