Connectivity issues across accounts and devices

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 22:27 IDT

Investigating

We are currently experiencing a connectivity issue affecting devices in Singapore. Some machines may appear offline. The issue is under investigation, and updates will be provided as more information becomes available.
Posted Jun 04, 2026 - 20:46 IDT
This incident affected: Asia-Pacific (Cellular Communication).