Monyx issue

Incident Report for Nayax

Resolved

After thorough investigation with our team, we have successfully resolved the issue. Thank you for your patience.
Posted Apr 08, 2025 - 11:24 IDT

Investigating

Our R&D team are still working on the fix. Hopefully, in the next hour, you should see the service back up and running. We apologize for any inconvenience this may cause.
Posted Apr 08, 2025 - 10:19 IDT
This incident affected: Nayax Global Solution (Monyx).