Billing provider transaction issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Sep 11, 2026 - 00:55 IDT

Monitoring

Transaction for Nuvei Canada are returning to normal levels. We are continuing to monitor the situation closely and will provide further updates if needed.
Posted Sep 10, 2026 - 23:53 IDT

Investigating

We are investigating an increased rate of transaction declines impacting Nuvei Canada. Updates will be provided as more information becomes available.
Posted Sep 10, 2026 - 23:31 IDT
This incident affected: North America (Transactions).