Services degraded performance

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 11:20 IDT

Investigating

The issue is still ongoing. Our engineering team is actively working to resolve it as quickly as possible. We will provide the next update once the status is changed or within the next hour - whichever comes first. Thank you for your patience and understanding.
Posted Aug 22, 2025 - 16:58 IDT

Identified

We are working to resolve an issue that affecting the creation of new operators on Nayax Core.
We will update you with further information as it becomes available.
Posted Aug 22, 2025 - 15:22 IDT
This incident affected: Nayax Global Solution (CORE).