Connectivity issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted May 07, 2026 - 15:40 IDT

Investigating

We are experiencing connectivity issues impacting customers in the Europe region. An email has been sent to the mobile provider, and an internal investigation is currently ongoing.
Posted May 07, 2026 - 15:12 IDT
This incident affected: Germany (Cellular Communication), France (Cellular Communication), United Kingdom (Cellular Communication), and Rest of Europe (Cellular Communication).