Prepaid cards decline issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 11:40 IDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 12, 2025 - 11:32 IDT

Investigating

We noticed that some prepaid cards are being declined due to exceeded daily limit, which was not yet passed. Our team is investigating this, and we will provide updates shortly.
Posted Sep 12, 2025 - 10:44 IDT
This incident affected: North America (Transactions).