Billing provider transaction issue-VisaNetDR

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 06:59 IDT

Investigating

We are in touch with VisaNetDR about a service outage with its billing gateway, which appears to be affecting all transactions. They are working on a resolution, and we will update you with further information as it becomes available.
Posted Apr 09, 2025 - 04:12 IDT
This incident affected: Latin America (Transactions), Africa & Middle East (Transactions), Asia-Pacific (Transactions), ישראל (Transactions), Germany (Transactions, Cellular Communication), France (Transactions), United Kingdom (Transactions, Cellular Communication), Rest of Europe (Transactions), North America (Transactions), and Australia & New Zealand (Transactions).