uncompleted Transactions - UNIPASS

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Aug 03, 2025 - 12:55 IDT

Investigating

We are currently investigating this issue.
Posted Aug 03, 2025 - 12:39 IDT
This incident affected: Germany (Transactions), France (Transactions), United Kingdom (Transactions), and Rest of Europe (Transactions).