Experiencing issues with the digital wallet service in Roseman.

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 21:46 IDT

Investigating

We are currently investigating this issue.
Posted Jun 11, 2025 - 09:29 IDT