Connectivity issues across accounts and devices

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 12:05 IST

Investigating

Our team is collaborating with our partners to resolve connectivity issues currently being experienced in United Kingdom. We will keep you updated with more information when we have it. Thank you for your understanding.
Posted Oct 29, 2025 - 10:45 IST
This incident affected: United Kingdom (Cellular Communication).