Decrease in Transactions – IL Region

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Feb 05, 2026 - 14:43 IST

Investigating

We are seeing a decrease in transaction volume in the IL region, impacting retail operations. Our teams are investigating. Updates will follow.
Posted Feb 05, 2026 - 13:50 IST
This incident affected: Israel (Transactions).