A high unsettled rate - Nuvei

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted May 08, 2025 - 01:14 IDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 08, 2025 - 00:20 IDT

Investigating

we’re experiencing a high unsettled rate from Nuvei (Unipass + SafeCharge). the operator is currently investigating the issue.
Posted May 07, 2025 - 22:18 IDT
This incident affected: ישראל (Transactions) and Rest of Europe (Transactions).