Billing provider transaction issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Oct 06, 2025 - 19:21 IDT

Monitoring

We have deployed the fix. We will continue to monitor the service until there are no signs of regression. Thank you for your patience.
Posted Oct 06, 2025 - 18:46 IDT

Identified

Our partner has a network issue they are working on. We are monitoring the situation while they are working on fixing the root cause and are now working on re-establishing consistent support to our network.
Posted Oct 06, 2025 - 16:27 IDT

Update

We are continuing to investigate this issue.
Posted Oct 06, 2025 - 15:20 IDT

Investigating

We are in touch with Travelbuy about a service outage with its billing gateway, which appears to be affecting all transactions. They are working on a resolution, and we will update you with further information as it becomes available.
Posted Oct 06, 2025 - 14:07 IDT
This incident affected: Africa & Middle East (Transactions).