Engine transaction time latency in US and DE

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Jun 09, 2025 - 12:32 IDT

Update

we are continuing investigating the issue, transactions are no longer affected.
Posted Jun 04, 2025 - 15:21 IDT

Investigating

Engine transaction time latency in US and DE that causes transaction decrease.
Our DBA team are investigating
Posted Jun 04, 2025 - 14:30 IDT
This incident affected: Germany (Transactions), United Kingdom (Transactions), and Rest of Europe (Transactions).