Issues with our online services

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 09:52 IDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 13, 2025 - 09:26 IDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 13, 2025 - 09:20 IDT

Investigating

We are currently experiencing issues with our online services and are actively working on a resolution to restore functionality as soon as possible
Posted Oct 13, 2025 - 09:19 IDT
This incident affected: ישראל (Transactions) and Rest of Europe (Transactions).