Billing provider transaction issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Sep 14, 2025 - 05:36 IDT

Investigating

We’re in contact with TravelBuy regarding a service outage affecting all transactions. Their team is working on a resolution. We’ll share further updates as soon as more information becomes available.
Posted Sep 14, 2025 - 02:14 IDT
This incident affected: Africa & Middle East (Transactions, Cellular Communication).