Fiscalization transactions issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Jun 09, 2025 - 12:32 IDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 26, 2025 - 21:12 IDT

Identified

Our R&D team has diagnosed the issue and is currently working to re-establish reliable service for our payment solution across the impacted regions in Ukraine. We are committed to keeping you updated as we make progress
Posted May 26, 2025 - 18:09 IDT
This incident affected: Rest of Europe (Transactions).