Replication issues and server latency

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Nov 05, 2025 - 12:20 IST

Investigating

Due to connection issues with the US we are experiencing visual issues with silent machines. Please be assured that issues are visual only.
We apologize for the inconvenience caused and will provide more information as it becomes available.
Posted Nov 05, 2025 - 11:52 IST
This incident affected: Nayax Global Solution (CORE).