Increased Transaction Processing Latency (US)

Incident Report for Nayax

Resolved

Transaction processing has returned to normal in the US region.
We are continuing to investigate the root cause and are monitoring closely to ensure stability.
Posted Apr 21, 2026 - 09:34 IDT

Update

We are continuing to investigate this issue.
Posted Apr 21, 2026 - 09:26 IDT

Investigating

We are currently investigating increased transaction processing times affecting the US region.
Our teams are analyzing engine performance and related dependencies to identify the root cause.
Further updates will be shared as more information becomes available.
Posted Apr 21, 2026 - 09:26 IDT
This incident affected: Latin America (Transactions), North America (Transactions), and Australia & New Zealand (Transactions).