High Transaction time in US

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Jan 05, 2026 - 10:16 IST

Investigating

We are currently investigating this issue.
Posted Jan 04, 2026 - 17:45 IST
This incident affected: North America (Transactions).