Identified - partner - processing

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 08:43 IDT

Identified

Our partner has a located the issue and is fixing the problem.
We are working to re-establishing our complete service as soon as possible.
Posted Jul 02, 2025 - 08:24 IDT
This incident affected: Africa & Middle East (Transactions).