Billing provider M-Pesa transaction issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 23:52 IDT

Investigating

We are in touch with M-Pesa regarding no transactions and we will update you with further information as it becomes available.
Posted Apr 23, 2025 - 22:52 IDT
This incident affected: Africa & Middle East (Transactions).