Website connection issues.

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted May 20, 2026 - 23:34 IDT

Monitoring

We have deployed the fix. We will continue to monitor the service until there are no signs of regression. Thank you for your patience.
Posted May 20, 2026 - 22:31 IDT

Update

We are continuing to investigate the issue.
Posted May 20, 2026 - 18:28 IDT

Investigating

We have identified intermittent connection issues with websites such as Nayax.com, Monyx.com and Tigapo.nayax.com. Our teams are working to resolve this issue as soon as possible, we will continue to provide updates as they become available.
Posted May 20, 2026 - 17:05 IDT