Service issue in a specific region

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 10:50 IDT

Update

The issue is still ongoing. Our engineering team is actively working to resolve it as quickly as possible. We will provide the next update once the status is changed or within the next hour - whichever comes first. Thank you for your patience and understanding.
Posted Aug 26, 2025 - 20:56 IDT

Investigating

We are working to get our solution back up and running ASAP, following a service issue.
Posted Aug 26, 2025 - 17:37 IDT
This incident affected: Nayax Global Solution (Monyx).