connectivity issues in Europe

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Apr 12, 2026 - 02:37 IDT

Investigating

We are currently experiencing intermittent connectivity issues affecting a limited number of customers in the Europe region.
Our teams are actively investigating the issue and working to identify the cause. We will provide updates as more information becomes available.
Posted Apr 12, 2026 - 01:51 IDT
This incident affected: Rest of Europe (Cellular Communication).