Billing provider transaction issue - CreditCall

Incident Report for Nayax

Resolved

As CreditCall informed us the previously reported service incident is now resolved and all systems should be back to normal operation.
Posted Jun 04, 2025 - 19:39 IDT

Investigating

We are in touch with CreditCall about a service outage with its billing gateway, which appears to be affecting transactions.
They are working on a resolution, and we will update you with further information as it becomes available.
Posted Jun 04, 2025 - 14:35 IDT
This incident affected: North America (Transactions).