Connectivity issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted May 18, 2025 - 16:06 IDT

Investigating

We are facing some intermittent connectivity issues affecting our customers in Poland region. Our R&D team is investigating this on priority, and we will keep you posted on the progress.
Posted May 18, 2025 - 15:45 IDT
This incident affected: Rest of Europe (Cellular Communication).