Website Connectivity issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 21:16 IDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 03, 2026 - 21:08 IDT

Identified

Our team has identified the issue and is now working on re-establishing a consistent connection. We promise to keep you updated as the work they're doing progresses.
Posted Jun 03, 2026 - 19:26 IDT

Investigating

We are facing some intermittent connectivity issues with Websites Nayax.com and otipetrosmart.com. Our team is investigating this on priority, and we will keep you posted on the progress.
Posted Jun 03, 2026 - 18:52 IDT