Website Connectivity Issues

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 18:22 IDT

Identified

Our R&D team has identified the issue and is now working on re-establishing consistent support. We promise to keep you updated, as the work they're doing progresses.
Posted Apr 16, 2026 - 11:56 IDT

Monitoring

We have deployed the fix. We will continue to monitor the service until there are no signs of regression. Thank you for your patience.
Posted Apr 16, 2026 - 11:36 IDT

Investigating

We are facing some intermittent website connectivity issues. Our R&D team is investigating this on priority, and we will keep you posted on the progress.
Posted Apr 16, 2026 - 10:40 IDT