Billing provider transaction issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 22:15 IST

Investigating

We are in touch with Nuvei Canada about a service outage with its billing gateway, which appears to be affecting all transactions. We will update you with further information as it becomes available.
Posted Nov 06, 2025 - 21:07 IST
This incident affected: Latin America (Transactions).