Billing provider transaction issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Dec 08, 2025 - 15:18 IST

Monitoring

We are no longer seeing declines related to this event, we will continue to monitor the service until there are no signs of regression. Thank you for your patience.
Posted Dec 08, 2025 - 13:53 IST

Investigating

We are in touch with ProvisionPay about a service outage with its billing gateway, which appears to be affecting transactions. We will update you with further information as it becomes available.
Posted Dec 08, 2025 - 13:15 IST
This incident affected: Rest of Europe (Transactions).