Identified - partner - network

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Jun 09, 2025 - 12:33 IDT

Identified

Our partner has a network issue they are working on. We are monitoring the situation while they are working on fixing the root cause and are now working on re-establishing consistent support to our network.
Posted May 29, 2025 - 11:23 IDT
This incident affected: ישראל (Cellular Communication).