Connectivity issues across devices in Israel.

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted May 15, 2025 - 14:17 IDT

Investigating

Our team is collaborating with our partners to resolve connectivity issues currently being experienced by Partner mobile provider in Israel. We will keep you updated with more information when we have it. Thank you for your understanding.
Posted May 15, 2025 - 01:42 IDT
This incident affected: ישראל (Cellular Communication).