Billing Provider: Innovorder- Decline In Transactions.

Incident Report for Nayax

Resolved

This incident has been resolved, no current issues with the approval of transactions.
Posted Jul 02, 2025 - 13:33 IDT

Investigating

We are in touch with the billing provider: Innovorder about a service outage with its billing gateway, which appears to be affecting transactions. We will update you with further information as it becomes available.
Posted Jun 30, 2025 - 11:09 IDT
This incident affected: France (Transactions).